Вопрос по информатике:
требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры
- 04.05.2015 05:07
- Информатика
- remove_red_eye 6197
- thumb_up 29
Ответы и объяснения 1
Var a,b:integer; x:real;
begin
readln (a,b);
x:=abs(b/a);
writeln (x:0:2);
end.
АБС это модуль, но я могу и ошибаться, тогда
var a,b:integer; x:real;
begin
readln (a,b);
If a<0 then a:=a*(-1);
If b<0 then b:=b*(-1);
x:=abs(b/a);
writeln (x:0:2);
end.
- 05.05.2015 23:59
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.