Вопрос по информатике:
Определить, можно ли квадрат со стороной a поместить в окружность заданного радиуса R?
Входные данные:
Во входном потоке задано два вещественных числа - радиус окружности R и сторона квадрата a. Значение всех исходных величин не превышает 30000.
Выходные данные:
В выходной поток вывести 'YES' или 'NO'.
Пример входного файла
2 1
Пример выходного файла
YES
- 25.12.2017 05:55
- Информатика
- remove_red_eye 16923
- thumb_up 44
Ответы и объяснения 1
Программа на Паскале:
Program BiFi;
Var R,a:real;
Begin
readln(R,a);
if a<=(R*sqrt(2)) then writeln('Yes');
else writeln('NO');
readln;
end.
- 26.12.2017 15:52
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.