Вопрос по информатике:
Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова.
Написать программу в Pascal.
- 09.12.2017 09:29
- Информатика
- remove_red_eye 16271
- thumb_up 37
Ответы и объяснения 1
Var a,b,c:integer;
p,n:string;
begin
readln(p)
;For a:=1 to length(p) do
begin
n:=copy(p,a,1);
If (n=' ') or (n=',') then
begin
If b>c then c:=b;
b:=0
end
else
b:=b+1;
end;
If c=0 then c:=b;
writeln (c);
end.
- 01.01.1970 00:00
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.