Вопрос по информатике:
Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.
Входные данные:
Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.
Выходные данные:
В выходной поток вывести 'YES' или 'NO'.
Пример входного файла
5 4 5
Пример выходного файла
YES
- 02.12.2017 22:52
- Информатика
- remove_red_eye 18167
- thumb_up 24
Ответы и объяснения 1
Var a,b,c:real;
begin
writeln('Vvedite 3 chisla');
readln(a,b,c);
if (a>=b) and (a>=c) then
writeln('yes') elso
writeln('no');
end.
примерно так, могут быть ошибки, но алгоритм ясен
- 03.12.2017 13:38
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.