Вопрос по информатике:
Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу:
А × В = НОД(А, В) × НОК(А, В).
- 22.11.2017 15:30
- Информатика
- remove_red_eye 15315
- thumb_up 19
Ответы и объяснения 1
var a, b, c, d, i, n :integer;
procedure swap (a, b :integer; c, d :integer);
begin
if a>b then begin c:=a; d:=a; end
else begin c:=b; d:=a; end;
end;
begin
read (a, b);
swap(a, b, a, b);
for i:=1 to a do if (a mod i=0) and (b mod i=0) then c:=i;
write (a*b/c);
end.
- 23.11.2017 20:54
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.