Вопрос по информатике:
Известны координаты вершин A, B, C треугольника. Напишите программу, вычисляющую площадь этого треугольника.
Пример входных данных: xa=2 ya=1 xb=6 yb=5 xc=10 yc=1
Пример выходных данных: S=16.0
- 17.04.2017 01:27
- Информатика
- remove_red_eye 5299
- thumb_up 49
Ответы и объяснения 1
// PascalABC.NET 3.3.5
begin
var xa, xb, xc, ya, yb, yc: real;
readln(xa, ya, xb, yb, xc, yc);
writeln(abs((xa - xc) * (yb - yc) - (xb - xc) * (ya - yc))/2);
end.
- 18.04.2017 15:28
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.