Вопрос по информатике:
Паскаль. В двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь один раз. Нужно написать программу.
- 09.02.2018 20:53
- Информатика
- remove_red_eye 7825
- thumb_up 40
Ответы и объяснения 1
Var matrix: array[1..5,1..5] of integer; i, j: integer; sg:=0; sp:=0;begin writeln ('Введите 25 чисел: '); for i := 1 to 5 do for j := 1 to 5 do read (matrix[i,j]); for i := 1 to 5 do begin for j := 1 to 5 do write (matrix[i,j], ' '); writeln end; for i:=1 to 5 do begin for j:= 1 to 5 do if j=i then sg:=sg+matrix[i,j]; end; for i:=5 downto 1 do begin for j:=1to 5 do if (i+j)=6 then sp:=sp+matrix[i,j] end; sp:=sp-matrix[3,3];1 writeln(sg,' ',sp);readlnend.
- 01.01.1970 00:00
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.