Вопрос по информатике:
Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не оказаться)
нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.
- 05.10.2017 06:22
- Информатика
- remove_red_eye 4909
- thumb_up 23
Ответы и объяснения 1
#include
#include
using namespace std;
int main ()
{ srand (time(NULL));
short N;
cout << "N=";
cin >> N;
int *array=new int [N];
cout << "Random array: ";
for (short i=0;i
array[i]=rand()%21-10;
cout << array[i] << ' ';
}
cout << endl;
for (short i=0;i
if (array[i]==0)
cout << "Nulls: " << array[i] << "(index=" << i << ')' << ' ';
}
system ("PAUSE>>VOID");
return 0;
}
- 06.10.2017 17:53
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.