Вопрос по информатике:
на паскале составить программу нахождения количества отрицательных элементов в заданном массиве из 10 действительных чисел
- 03.03.2018 11:01
- Информатика
- remove_red_eye 12716
- thumb_up 46
Ответы и объяснения 2
Var a, i:integer;
var arrayx = array[0..10] of integer;
begin
arrayx[0] = -1;
arrayx[1] = 3;
arrayx[2] = 5;
arrayx[3] = -3;
arrayx[4] = -2;
arrayx[5] = -7;
arrayx[6] = 2;
arrayx[7] = 3;
arrayx[8] = -10;
arrayx[9] = 0;
for i := 1 to 10 do
begin
if (arrayx[i] < 0) a:= a + 1;
end;
writeln("Отрицательных чисел: ", a);
readln;
end.
- 04.03.2018 11:45
- thumb_up 18
Program test;
const n = 10;
var i,k:integer;
m: array[1..n] of integer;
begin
for i:=1 to n do
begin
write(' Введите [',i,'] член масива: ');
readln(m[i]);
end;
for i:=1 to n do if m[i]<0 then inc(k);
writeln('Количество чисел меньших нуля :',k);
end.
- 05.03.2018 03:02
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.