Вопрос по информатике:
Pascal (Паскаль). Очень прошу помощи
Составить программу сортировки массива методом пузырька НО не использовать for
Только через repeat + использовать flag
Всего в программе должно быть 3 переменных: i,flag,b:integer;
Заранее благодарен, тому кто поможет свяжусь и отблагодарю отдельно
- 21.01.2016 08:36
- Информатика
- remove_red_eye 7679
- thumb_up 50
Ответы и объяснения 1
Program test;
const n = 5;
var i,flag,b:integer;
m:array [1..n] of integer;
begin
b:=1;
for i:=1 to n do
readln(m[i]);
repeat
b:=b+1;
if m[b]
flag:=m[b-1];
m[b-1]:=m[b];
m[b]:=flag;
b:=1;
end;
until b=n;
for i:=1 to n do
writeln(i,')',m[i]);
end.
P.S. я использую for только для записи и вывода
- 22.01.2016 19:09
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.