Вопрос по информатике:
помогите написать программу
Дан фрагмент:
for n:=l to 6 do
for m:=l to 5 do begin
C[n,m]:=C[n,m]+(2*n-m);
end;
Чему будет равно значение С[4,3], если перед этими командами значение С[4,3]=10?
Чему будет равно значение С[4,3], если перед этими командами значение С[4,3]=10?
- 15.07.2018 14:02
- Информатика
- remove_red_eye 12733
- thumb_up 40
Ответы и объяснения 1
Во первых ошибка во фрагменте там должны быть цыфирки 1, а не буква l
т.е for n:=1 to 6 do
for m:=1 to 5 do begin
Текст программы
Uses crt;
var c:array[1..6,1..5] of integer;
n,m:integer;
begin
с[4,3]:=10;
for n:=1 to 6 do
for m:=1 to 5 do begin
с[n,m]:=с[n,m]+(2*n-m);
if (m=5)then
writeln(c[n,m])
else write(c[n,m],' ');
end;
writeln;writeln;
write('C[4,3]=',C[4,3]);
readkey;
end.
Прогоночный вывод
1 0 -1 -2 -3
3 2 1 0 -1
5 4 3 2 1
7 6 15 4 3
9 8 7 6 5
11 10 9 8 7
Отсюда получаем что если с[4,3]:=10 перед началом цикла то с[4,3]=15
в противном случае с[4,3]=5
- 16.07.2018 03:59
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.