Вопрос по информатике:
Помогите пожалуйста написать программу)))
Даны два числа. Наименьшее из этих чисел возвести в квадрат, наибольшее в куб. Найти среднее арифметическое полученных данных.
- 23.12.2017 09:39
- Информатика
- remove_red_eye 6214
- thumb_up 33
Ответы и объяснения 1
Program gt;
var a,b,s,q:real;
begin
readln(a,b);
q:=0;
if(a>b)then begin
a:=a*a*a;
b:=b*b;
q:=1;
end;
if(q=0)then begin
b:=b*b*b;
a:=a*a;
end;
s:=(a+b)/2;
writeln(a,' ',b,' ',s);
end.
- 24.12.2017 14:43
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.