Вопрос по информатике:
Составить программу, которая определяет, являются ли разные точки с координатами (X1,Y1) и (X2, Y2) симметричными относительно осей координат или начала координат.прочертить путь выполнения алгоритма для следующих значений параметров:А) X1= -1, Y1=6, X2=1, Y2=6.Б) X1=6, Y1=7, X2=1, Y2=6
- 24.07.2015 17:20
- Информатика
- remove_red_eye 7173
- thumb_up 40
Ответы и объяснения 1
Progra mgt;
var x1,x2,y1,y2:real;
begin
readln(x1,y1,x2,y2);
if((x1=x2)and(y1=-y2))or((x1=-x2)and(y1=y2))or((x1=-x2)and(y1=-y2))then writeln('YES')
else writeln('NO');
end.
- 25.07.2015 21:12
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.