Вопрос по информатике:
.Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й — равен случайному двузначному числу; 2-й — равен целой части от деления случайного трехзначного числа на сумму индексов текущего элемента; 3-й — равен остатку от деления случайного двухзначного числа на 10.
- 01.07.2018 00:46
- Информатика
- remove_red_eye 16160
- thumb_up 21
Ответы и объяснения 1
Program arrays;
var a:array [1..3,1..6] of integer;
i,j:byte;
begin
for i:=1 to 3 do
for j:=0 to 1 do
begin
a[i,1+3*j]:=random(101)+10;
a[i,2+3*j]:=random((1001)+100) div (i+2*j);
a[i,3+3*j]:=(random(101)+10) mod 10;
end;
for i:=1 to 3 do
begin
for j:=1 to 6 do
write(a[i,j],' ');
writeln;
end;
end.
//Если нужны пояснения - пишите
- 02.07.2018 21:51
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.