Вопрос по информатике:
Помогите пожалуйста)))
Записать алгоритм и написать программу циклического перемещения влево значений между переменными а, b, c
- 23.10.2017 17:58
- Информатика
- remove_red_eye 1706
- thumb_up 18
Ответы и объяснения 1
Program gt;
var a,b,c,k:integer;
begin
read(k);
{k-на какое число шагов надо переместит числа a b c влево}
k:=k mod 3;
if(k=0)then writeln(a,' ',b,' ',c);
if(k=1)then writeln(b,' ',c,' ',a);
if(k=2)then writeln(c,' ',a,' ',b);
end.
- 24.10.2017 18:56
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.