Вопрос по информатике:
Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)
Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу: Найти номера первых двух рядом
стоящих одинаковых элементов в массиве.
Например, если А={2,6,4,4,2,5,5,4},
результат: 3 и 4.
- 13.11.2017 15:39
- Информатика
- remove_red_eye 7563
- thumb_up 14
Ответы и объяснения 1
Program random_;
uses crt;
type
arr = array[0..1000] of shortint;
var
ar,b,i:word;
a:arr;
begin
randomize;
for ar:=0 to 999 do
a[ar]:= random(18)-9;
b:=10;
i:=0;
repeat b:=a[i]; i:=i+1; until(b = a[i]) or (i = 999);
if i = 999 then writeln('Повторяющихся чисел нет!') else writeln(i,' ',i+1) ;
end.
- 14.11.2017 14:36
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.