Вопрос по информатике:
Написать программу вычисления величины
B = m(m-1)(m-2) … (m-(n-1))
,
где
m, n заданы
(m>n, m,n – натуральны
числа).
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 25.02.2017 21:37
- Информатика
- remove_red_eye 16387
- thumb_up 47
Ответы и объяснения 1
VAR
n, m, ans, i: UInt64;
BEGIN
Read(m, n);
ans := m;
For i := 1 to (n-1) do
ans := ans*(m - i);
Write(ans);
END.
- 26.02.2017 11:51
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.