Вопрос по информатике:
Составьте программу для вычисления площади четырёхугольника с координатами вершин (x1, y1),(x2, y2),(x3, y3),(x4, y4).Площадь четырёхугольника вычислите как сумму площадей двух треугольников.
- 21.04.2015 00:15
- Информатика
- remove_red_eye 9847
- thumb_up 39
Ответы и объяснения 1
TYPE
TPoint = Record x, y: Real; End;
VAR
a, b, c, d: TPoint;
Function Pl(a, b, c: TPoint): Real;
Var v1, v2: TPoint;
Begin
v1.x := a.x - b.x; v1.y := a.y - b.y;
v2.x := a.x - c.x; v2.y := a.y - c.y;
Pl := Abs(v1.x * v2.y - v1.y * v2.x) / 2;
End;
BEGIN
Read(a.x, a.y, b.x, b.y);
Read(c.x, c.y, d.x, d.y);
Write(Pl(a, b, c)+Pl(a, c, d));
END.
- 22.04.2015 04:33
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.