Вопрос по информатике:
Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К сожалению, проспать 14 часов ему не удалось, т.к. будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит.
Входные данные: Два целых числа S и T(1 < S < 24, T < 12) - час, когда исследователь лег спать, и час, на который он установил будильник.
Выходные данные: Целое число - через сколько часов зазвонит будильник.
- 20.09.2017 00:03
- Информатика
- remove_red_eye 13712
- thumb_up 8
Ответы и объяснения 2
Program gt;
var k,s,t:integer;
begin
read(s,t);
if(s<=12)then begin
if(s<=t)then k:=t-s;
if(s>t)then k:=t+12-s;
end;
if(s>12)then begin
if(s<=t+12)then k:=t+12-s;
if(s>t+12)then k:=24-s+t;
end;
writeln(k);
end.
- 21.09.2017 23:48
- thumb_up 29
VB.
Dim S As Integer ' 1<=S<=24
Dim T As Integer ' T<=12
S = InputBox("S=")
T = InputBox("T=")
Select Case S
Case Is <= T
MsgBox(T - S)
Case Is > T
If T = 12 Then MsgBox((T + 12) - S) Else MsgBox(24 - (S - T))
End Select
- 22.09.2017 16:43
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.