Вопрос по информатике:
Для приведенной ниже числовой последовательности написать программу для вычисления числа:
1/1*3-1/3*5+1/5*7-1/7*9+.....+1/101*103-1/103*105
- 14.04.2018 03:16
- Информатика
- remove_red_eye 9173
- thumb_up 32
Ответы и объяснения 1
Program gt;
var p:real;
a,b,w:integer;
begin
a:=-1;
b:=1;
w:=-1;
while a<=103 do
begin
a:=a+2;
b:=b+2;
w:=w*-1;
p:=p+1/a*b*w;
end;
writeln(p);
end.
2)
program gt;
var p:real;a,b,w:integer;
begin
a:=-1;b:=1;w:=-1;p:=0;
while a<=103 do
begin
a:=a+2;
b:=b+2;
w:=w*-1;
p:=p+(1/(a*b))*w;
end;
writeln(p);
end.
1-первый случай
2-второй случай
- 15.04.2018 12:41
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.