Вопрос по информатике:
2. Написать программу, которая вводит массив из N целых чисел и выводит на экранномера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов: а) 3,5,-2,0,-6,-8,1б) -1,-2,-3,-4,0,-1,2,3. Пожалуйста)))
- 08.09.2017 03:20
- Информатика
- remove_red_eye 15192
- thumb_up 43
Ответы и объяснения 1
Var
mas:array[1..100] of real;
i:integer;
y:string;
Begin
write('Вводите элементы массива, когда закончите введите Y: ');readln(y);
for i:=1 to 100 do begin
if (y='Y') then i:=101
else begin
mas[i]:=strTofloat(y);
readln(y); end;End;
for i:=1 to 100 do begin
if (mas[i]<0) then writeln('Номер элемента:',i,' Элемент:',mas[i]);end;
End.
- 09.09.2017 22:59
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.