Вопрос по информатике:
Вы посетили магазин и купили 10 видов товара.В таблицу T[1:10] вы записали количество купленного товара каждого вида.В таблицу C[1:10] записали цены единиц каждого вида товара соответственно.Составьте алгоритм вычисления общей стоимости всех покупок.
помогите семестровая решается очень нужно)))
- 07.10.2015 20:06
- Информатика
- remove_red_eye 5298
- thumb_up 31
Ответы и объяснения 1
Const n = 10;
var
T: array [1..n] of integer;
C: array [1..n] of real;
i: integer;
sum: real;
begin
sum := 0;
for i := 1 to n do
begin
readln(T[i], C[i]);
sum := sum + T[i] * C[i];
end;
writeln;
writeln('sum = ',sum);
end.
- 08.10.2015 13:15
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.