Вопрос по информатике:
Написать программу нахождения сопротивления цепи из n резисторов (r1,r2, ..rn) соединённых последовательно (PascalABC)
- 16.10.2017 09:08
- Информатика
- remove_red_eye 17181
- thumb_up 15
Ответы и объяснения 2
При последовательном соединении сопротивление цепи будет равно сумме сопротивлений.
uses crt;
var r:array [1..10000] of integer;
n,x,RSum:integer;
begin
RSum:=0;
write('N='); readln(N);
for x:=1 to N do
begin
write('R',x,'=');
readln(r[x]);
RSum:=RSum+r[x];
end;
writeln('R=',RSum);
end.
- 17.10.2017 16:14
- thumb_up 51
Var a, n, i, s : integer;
begin
read (n);
for i:=1 to n do
begin
read (a);
s:=s+a;
end;
write (s);
end.
В последовательном соединении
P.S. Надеюсь на благодарность и лучший ответ.
- 18.10.2017 01:30
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.