Вопрос по информатике:
написать программу находящую количество цифр вводимого неотрицательного положительного числа
- 09.01.2017 09:11
- Информатика
- remove_red_eye 12275
- thumb_up 50
Ответы и объяснения 1
Var
a, c : integer;
begin
readln (a);
c := 0;
if (a = 0) then c := 1
else
while a 0 do
begin
c := c + 1;
a := a div 10;
end;
writeln (c);
end.
- 01.01.1970 00:00
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.