Вопрос по информатике:
Написать программу в C++
Дан одномерный массив x из n элементов.
Найти порядковый номер первого по счёту
положительного элемента с чётным порядковым номером. Все отрицательные элементы
после него переписать в массив y.
- 17.04.2018 23:00
- Информатика
- remove_red_eye 15148
- thumb_up 45
Ответы и объяснения 1
#include
#include
#include
#include
int odd(int i)
{
return 2 * i + 1;
}
int square(int i)
{
return i * i;
}
typedef boost::counting_iterator counter;
typedef boost::transform_iterator transformer;
transformer odds(int n)
{
return transformer(counter(n), odd);
}
transformer squares(int n)
{
return transformer(counter(n), square);
}
int main()
{
using namespace std;
cout << "Enter vector length: ";
int n; cin >> n;
cout << inner_product( odds(0), odds(n), squares(0), 0 ) << endl;
- 18.04.2018 16:08
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.