Вопрос по информатике:
Перестановкой из n чисел называется-последовательность чисел,где каждое число от 1 до n встречается ровно один раз.Перестановка b1,b2...bN является обратной перестановкой перестановки a1,a2...aN, если b[ai]=1=i для каждого i от 1 до n.для заданных двух перестановок определите является ли вторая перестановка обратной первой
Формат входных данных
В певой строке входного файла записано одно целое число n (1<=n<=1000)-размер перестановок.Во второй запписаны n целых чисел b1,b2...bN (1<=bi<=n)-вторая перестановка.
Формат выходных данных
В единственной строке выходного файла выведите одно слово "YES",если вторая перестановка является обратной первой.Иначе выведите "NO".
- 08.08.2017 13:03
- Информатика
- remove_red_eye 12962
- thumb_up 30
Ответы и объяснения 2
uses crt;
var i,j,k,n,sum:integer;
a:array[1..100] of integer;
flag:boolean;
begin
flag:=false;
writeln('Input N');
read(n);
writeln('Input elements');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
for j:=1 to n do
for k:=1 to n do
if (ij) and (jk) and (ik) then
if a[i]+a[j]+a[k]=0 then
f flag=false then
writeln('No');
end. uses crt;
var i,j,k,n,sum:integer;
a:array[1..100] of integer;
flag:boolean;
begin
flag:=false;
writeln('Input N');
read(n);
writeln('Input elements');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
for j:=1 to n do
for k:=1 to n do
if (ij) and (jk) and (ik) then
if a[i]+a[j]+a[k]=0 then
f flag=false then
writeln('No');
end.
- 09.08.2017 13:29
- thumb_up 14
Мы судьи с "ЕртисДарына" Ваша школа будет дисквалефецирована!
Мы нашли вас по вашему 'Ip' коду
- 01.01.1970 00:00
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.