Вопрос по информатике:
Задано существительное 1-го склонения, оканчивающееся на «а». Составьте программу, позволяющую вывести на экран это слово во всех падежах.
- 26.02.2018 14:41
- Информатика
- remove_red_eye 7214
- thumb_up 30
Ответы и объяснения 1
Var a: string;
begin
write ('Введите слово: '); read (a);
writeln ('Именительный падеж: ',copy(a,1,length(a)));
writeln ('Родительный падеж: ',copy(a,1,length(a)-1),'ы');
writeln ('Дательный падеж: ',copy(a,1,length(a)-1),'е');
writeln ('Винительный падеж: ',copy(a,1,length(a)-1),'у');
writeln ('Творительный падеж: ',copy(a,1,length(a)-1),'ой');
writeln ('Предложный падеж: ',copy(a,1,length(a)-1),'е');
end.
Основной момент, это удаление окончания путем копирования слова в строке a начиная с первого символа, до длины слова минус 1 символ.
- 27.02.2018 12:52
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.