Вопрос по информатике:
Задача:
Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.
Помогите пожалуйста решить!
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 03.02.2016 00:35
- Информатика
- remove_red_eye 16529
- thumb_up 38
Ответы и объяснения 2
Var a:array [1..10] of integer;
i,n,b:integer;
Begin
for i:=1 to 10 do
read(a[i]);
for i:=1 to 10 do
begin
if b=0 then if a[i]<0 then
begin
a[i]:=0;
b:=1;
end;
end;
for i:=1 to 10 do
write(a[i],' ');
End.
- 04.02.2016 22:10
- thumb_up 18
Program z10;
var a,b:Array [1..10] of integer;
i,q:integer;
Begin
Randomize;
q:=0;
For i:=1 to 10 do
begin
a[i]:=random(40)-20;
write(a[i],' ');
if(a[i]<0)then begin
q:=q+1;
if(q=1)then a[i]:=0;
end;
end;
writeln;
for i:=1 to 10 do
begin
write(a[i],' ');
end;
end.
- 05.02.2016 22:34
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.