Вопрос по информатике:
напишите программу на любом известном Вам алгоритмическом языке. На вход программе подается число N. Далее вводится N чисел. Программа определяет, будет ли произведение этих чисел положительным
- 17.02.2018 20:36
- Информатика
- remove_red_eye 3389
- thumb_up 39
Ответы и объяснения 2
Паскаль
uses crt;
var n,pr,x:integer;
a: array [1..1000] of integer;
begin
write('Введи количество чисел последовательности:');
readln(n);
pr:=1;
for x:=1 to N do
begin
readln(a[x]);
pr:=pr*a[x];
end;
if pr>0 then writeln('YES')
else writeln('NO');
end.
- 18.02.2018 11:43
- thumb_up 6
Произведение чисел положительно, если среди них есть четное количество отрицательных чисел. И отрицательно, если их нечетное количество.
Я просто алгоритм напишу
1) Вводим число N
2) Устанавливаем счетчик k = 0
3) Цикл по i от 1 до N
3.1) Вводим очередное число
3.2) Если число < 0, то прибавляем счетчик k = k + 1
3.3) Конец цикла
4) Если число k четное (k mod 2 = 0), то результат положительный
Если k нечетное (k mod 2 = 1), то результат отрицательный.
5) Конец
А вот делать так, как Sky предлагает, я бы не стал. Он тупо перемножает числа.
Произведение может оказаться слишком большим, да оно нам и не нужно.
- 19.02.2018 06:47
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.