Вопрос по информатике:
Найти сумму всех целых чисел больше -50, но меньше 200, которые кратны 5(делятся на 5). Напишите программу, пожалуйста.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 23.03.2017 01:32
- Информатика
- remove_red_eye 16152
- thumb_up 44
Ответы и объяснения 1
Program
project1;
uses
crt,math;
constn=10;
var s:real; i:byte; a:array [1..10] of integer;
begin
for i:=1 to n do
begin
writeln('vvedite ',i,' cifru');readln(a[i]);
end;
for i:=1 to n do
begin
if ((a[i]>-50) and (a[i]<200) and ((a[i] mod 5) = 0)) then s:=s+a[i];
end;
writeln('summa vseh: ',s:2:2);
readln;
end.
- 24.03.2017 04:00
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.