Вопрос по информатике:
Помогите пожалуйста
Даны 3 числа a,b,c. Определить минимальное из них. Если минимальное число окажется отрицательным , то определить количество отрицательных чисел , а иначе все положительные числа заменить на отрицательные .
Написать программу и блок схему
- 12.11.2017 01:06
- Информатика
- remove_red_eye 1922
- thumb_up 43
Ответы и объяснения 1
Program project1;
uses
crt,math;
var s:real; i,j,f:real; a:integer;
begin
writeln('vvedite 1 chislo ');readln(i);
writeln('vvedite 2 chislo ');readln(j);
writeln('vvedite 3 chislo ');readln(f);
s:=i;
if j if f if s<0 then
begin
if i<0 then inc(a);
if j<0 then inc(a);
if f<0 then inc(a);
writeln('kolichestvo otricatelnix ',a:2);
end
else
begin
if i>0 then i:=i*-1;
if j>0 then j:=i*-1;
if f>0 then f:=i*-1;
end;
writeln('min chislo ',s:2:0);
readln;
end.
- 13.11.2017 05:47
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.