Вопрос по информатике:
Составить программу:
1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания
2. Задано четырехзначное число. Удалить из записи числа последнюю цифру. Определить, будет ли оставшееся число кратно 11
- 07.04.2018 00:09
- Информатика
- remove_red_eye 5593
- thumb_up 44
Ответы и объяснения 1
1.
uses crt;
var x:integer;
begin
read(x);
if inttostr(x)[1]>inttostr(x)[5] then
writeln(inttostr(x)[1],' ',inttostr(x)[5])
else
writeln(inttostr(x)[5],' ',inttostr(x)[1]);
end.
2.
uses crt;
var x:integer;
begin
read(x);
if (x div 10) mod 11=0 then
writeln('Yes')
else
writeln('No');
end.
- 07.04.2018 23:02
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.