Вопрос по информатике:
Составить программу (в Pascal) позволяющую найти минимальный элемент массива. Подсчитать количество элементов в массиве, равных минимальному. Размеренность массива произвольная.
- 05.11.2017 02:37
- Информатика
- remove_red_eye 12231
- thumb_up 32
Ответы и объяснения 2
Program my;
var k,i,z:integer;
a:array[1...N]:integer;
begin
k:=99999;
for i:=1 to N do
if a[i]
for i:=1 to N do
if a[i]=k then z:=z+1;
end.
=)
- 06.11.2017 11:39
- thumb_up 34
Uses crt;
const N=10;
var a:array [1..N] of integer;
x,min,k:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:',a[x]);
readln(a[x]);
end;
min:=a[1];
for x:=1 to N do
if a[x]
if a[x]=min then inc(k);
writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k);
end.
- 07.11.2017 04:15
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.