Вопрос по информатике:
Какое значение примет К после выполения алгоритма
Х:=0:K:=5
выбор
при x<5:K:=3
при x<=0:K:=2
иначе K:=0
все Пожайлуста напишите программу.Мы сейчас проходим оператор case!
- 11.02.2017 22:32
- Информатика
- remove_red_eye 17406
- thumb_up 31
Ответы и объяснения 2
Program Number1;
Var
x, k: integer;
Begin
writeln(‘Введите x‘);
readln(x);
if (x9)
then
writeln (‘Это число не является цифрой‘)
else
case x of
1,2,3,4 : k:=3;
else:
if (x<=0)
then
k:=2;
else
k:=0;
end;
readln;
End.
- 12.02.2017 12:16
- thumb_up 6
var
x, k: integer;
begin
x := 0;
k := 5;
case x of
1..4: k := 3;
0: k := 2;
else k := 0;
end;
writeln('k = ', k);
end.
- 13.02.2017 08:51
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.