Вопрос по информатике:
Составьте программу, котораяСоставьте программу, которая заполняет массив а[1"10 ] случайными числами в диапазоне от 0 до 10 , затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.
- 03.12.2017 17:20
- Информатика
- remove_red_eye 18639
- thumb_up 37
Ответы и объяснения 1
uses crt;
const N=10;
var a:array [1..N] of integer;
x,pos,max:integer;
begin
randomize;
for x:=1 to N do
begin
a[x]:=random(11);
writeln('a[',x,']:',a[x]);
end;
max:=1;
for x:=1 to N do
if a[x]>a[max] then max:=x;
pos:=a[1];
a[1]:=a[max];
a[max]:=pos;
writeln;
for x:=1 to N do
writeln('a[',x,']:',a[x]);
end.
- 04.12.2017 22:22
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.