Вопрос по информатике:
Написать программу на С++ помогите пожалуйста.
Найти сумму элементов последовательности b1,b2........ , b15 , расположенных правее последнего отрицательного элемента и номер этого элемента.
- 07.06.2018 01:50
- Информатика
- remove_red_eye 10035
- thumb_up 37
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int a[15];
int i = 0;
int sum = 0;
for (; i < 15; i++)
cin >> a[i];
for (i = 14; (i != 0) && (a[i]>0); i--)
sum += a[i];
cout << "i = " << i+1 << endl;
cout << "summa = " << sum << endl;
return 0;
}
- 08.06.2018 21:18
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.