Вопрос по информатике:
составить программу в Паскале
Массив A(M,N) заполнить случайными числами из промежутка [-15;-8] и подсчитать произведение элементов чётных строк.Исходный массив и результат вывести на экран
- 06.02.2016 21:52
- Информатика
- remove_red_eye 2960
- thumb_up 36
Ответы и объяснения 1
Вместо 20 можно подставить любое число, 20 соответствует M,N
program new;
var a:array [1..20,1..20] of integer; i,j,sum:integer;
begin
randomize;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
a[i,j]:=random(8)-15
end;
end;
for i=2 to 20 do
begin
for j=1 to 20 do
begin
sum:=sum+a[i,j];
i:=i+2;
end;
end;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
write(a[i,j]);
end;
writeln;
end;
writeln('Сумма равна ',sum:8);
end.
P.S.
Делал без паскаля если какие то ошибки то пиши
- 08.02.2016 00:33
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.