Вопрос по информатике:
Составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и:
а) находит элементы с нулевыми значениями;
б) находит индексы четных элементов;
в) подсчитывает кол-во отрицательных элементов;
г) Определяет, есть ли в этом массиве хотя бы одно число, кратное трем;
д) находит в этом массивеиндексы элементов, значения которых кратны трем;
Помогите, пожалуйста
- 09.07.2018 02:51
- Информатика
- remove_red_eye 2563
- thumb_up 10
Ответы и объяснения 1
Const n=16; minr=-20; maxr=20;
var a:array[1..n] of integer; k,i:integer; t:boolean;
begin
for i:=1 to n do begin a[i]:=random(maxr-minr+1)+minr; write(a[i],' ') end;
writeln;
k:=0;
for i:=1 to n do begin if (a[i] mod 2=0) and (a[i]0) then write(i,' '); if a[i]<0 then k:=k+1 end;
writeln;
writeln(k);
t:=false;
for i:=1 to n do if (a[i] mod 3=0) and (a[i]0) then begin if t=false then begin writeln(true); t:=true end; write(i,' ') end;
if t=false then writeln(false)
end.
- 01.01.1970 00:00
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.