Вопрос по информатике:
Помогите написать программу на Паскале.
Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).
Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.
Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.
- 23.05.2018 05:53
- Информатика
- remove_red_eye 7133
- thumb_up 31
Ответы и объяснения 1
Uses crt;
var a,sum:integer;
begin
sum:=0;
repeat
read(a);
if (a mod 6=0) or (a mod 11=0) then sum:=sum+a;
until a=0;
writeln(sum);
end.
- 24.05.2018 03:41
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.