Вопрос по информатике:
Решите в паскале. Составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8, r8, r9, r10, r11, r12, r13, r14, r15, r16, r17, r18, r19, r20 соединение паралельное. Сопротивления заданы в массиве, напряжение вводится.
- 20.12.2016 23:44
- Информатика
- remove_red_eye 2648
- thumb_up 43
Ответы и объяснения 1
Uses crt;
const R: array[1..20] of integer =(1, 2, 3, 4, 5, 6, 7, 8, 9, 10,
11, 12, 13, 14, 15, 16, 17, 18, 19, 20);
var I:array [1..20] of real;
U,x:integer;
SUM:real;
begin
write('U='); readln(U);
for x:=1 to 20 do
begin
write('R[',x,']:',R[x],' ');
I[x]:=U/R[x];
SUM:=SUM+I[x];
writeln('I[',x,']:',I[x]:5:3);
end;
writeln('I=',SUM:5:3);
end.
- 21.12.2016 12:18
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.