Вопрос по информатике:
Задача 1. Составить программу, которая запрашивает у пользователя
два числа (m, n), находит их сумму (S) и произведение (P). Сравнивает значения суммы
и произведения и выводит сообщение какое больше (сумма или произведение) и на
сколько.
Иногда в задачах требуется выполнение не одного, а нескольких условий или
одного из нескольких. Тогда простые условия образуют составные при помощи логических
операций and или or.
Формат записи
составного условия:
(условие 1) and (условие
2) and…and (условие
N)
(условие 1) or (условие
2) or…or (условие N)
Задача 2. В школу
танцев принимаются учащиеся не выше 178 см и не ниже 168 см. Написать программу,
которая определяет, будете ли Вы приняты в школу танцев.
Условие:
if (rost<178) and (rost>168) then write (‘Приняты!‘) else write (‘ Не приняты!‘);
Задача 3. Составить
программу, которая определяет, является ли данное число трехзначным и выводит
сообщение об этом (двузначным является число от 10 до 99).
Задача 4. На работу в компанию принимаются люди не старше 42 лет и
имеющие стаж работы не менее 5 лет. Написать программу, которая определяет,
будет кандидат принят на работу или нет.
Задача 5. Дано некоторое число b. Составить программу, которая удваивает данное число если оно,
принадлежит интервалу [m;n], ыв противном случае
заменяет его на противоположное.
PS: pascal(не турбо),всем буду благодарен!
- 27.05.2018 06:17
- Информатика
- remove_red_eye 8853
- thumb_up 27
Ответы и объяснения 1
Задание 2
Program ada4a2;
Var rost:Integer;
Begin
WriteLn('Введите ваш возраст: ');
Read(rost);
If (rost168) Then Write('Приняты')
Else Write('Не приняты');
ReadLn;
End.
- 28.05.2018 09:25
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.