Вопрос по информатике:
Напишите программу на любом известном вам алгоритмическом языке. На вход программе подается число N. Программа формирует N случайных чисел и вычисляет их сумму.
- 20.04.2018 17:59
- Информатика
- remove_red_eye 9738
- thumb_up 9
Ответы и объяснения 1
Ну так как знаю язык программы Dev-C++, напишу.... и если я не ошибаюсь это массив :-)
#include
main()
{
int i, n;
float s;
printf("n=");
scanf("%d", &n);
int a[n];
for(i=0; i {
printf("\n a[%d]=", i);
scanf("%d", &a[i]);
}
s=0;
for(i=0; i s=s+a[i];
printf("s=%f", s);
puts("Massiv:");
for(i=0; i printf("\n a[%d]=%d", i, a[i]);
getchar();
return(0);
}
напишу краткое объяснение, 1- пишем н, произвольное, это количемтво этих исел будет,
2- создаем массив с и ( параметр массива) меньшим н.... там мы пишем эти числа, сумму которых нужно всчитать
3- находим сумму
4- пишем чемк она равна
5- выводим массив
и все
если программа не бкдет идти напиши вконце место return(0); => getchar();
- 21.04.2018 05:36
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.