Вопрос по информатике:
Задача 3. Написать программу, определяющую, лежит ли точка с
указанными координатами А (x, y) на окружности радиуса R с центром в начале
координат (может лежать на окружности, внутри окружности, вне окружности)
PS: Pascal(не турбо)
Всем буду благодарен!
- 20.07.2015 00:51
- Информатика
- remove_red_eye 12246
- thumb_up 15
Ответы и объяснения 1
Var
x,y, r: Iinteger;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln®;
If (sqr(x)+sqr(y))=r then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
- 20.07.2015 12:57
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.