Вопрос по информатике:
Задается последовательность целых чисел. Сколько чисел отличается от первого на 1 ?Написать программу на паскале без использования массивов
- 01.03.2018 01:46
- Информатика
- remove_red_eye 13631
- thumb_up 24
Ответы и объяснения 1
Uses crt;
var n, a, b, k:integer;
begin k:=0;
writeln ('Сколько цифр будет в строке?');
read (n);
writeln ('Вводите числа, после каждого ENTER.');
read (b);
for n:=1 to n-1 do
begin
read (a);
if a+1=b then k:=k+1 else
if a-1=b then k:=k+1;
end;
writeln ('Количество чисел отстающих на 1 от первого числа - ',k);
end.
- 02.03.2018 08:36
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.