Вопрос по информатике:
Помогите , пожалуйста . Нужно написать программу для Паскаль.
Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.
program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.
- 02.08.2016 12:06
- Информатика
- remove_red_eye 7334
- thumb_up 15
Ответы и объяснения 1
Program ru;
var a,b,c,d,e,max:integer;
begin
writeln('Введите пять целых чисел');
readln(a,b,c,d,e);
max:=a;
if b>max then
max:=b;
if c>max then
max:=c;
if d>max then
max:=d;
if e>max then
max:=e;
writeln('Наибольшее число равно ', max);
end.
- 03.08.2016 07:41
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.