Вопрос по информатике:
составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие
- 10.07.2018 19:07
- Информатика
- remove_red_eye 8650
- thumb_up 42
Ответы и объяснения 1
const
s: array [1..6] of char= ('б','в','г','д','ж','з');
d: array [1..6] of char= ('п','ф','к','т','ш','с');
var
c: string;
i,j: integer;
begin
readln(c);
for i:= 1 to length(c) do
for j:= 1 to 6 do
if d[j]=c[i] then c[i]:= s[j]
else
if s[j]=c[i] then c[i]:= d[j];
writeln(c)
end.
- 11.07.2018 21:03
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.