Вопрос по информатике:
Написать программу из 2 частей. В основной программе посчитать сумму факториалов всех нечетных чисел с 1 до 9. Подсчет факториалов реализовать в функции
- 23.09.2017 11:02
- Информатика
- remove_red_eye 15580
- thumb_up 19
Ответы и объяснения 2
Program gt;
var i,s,l:integer;
function IOI(a:integer):integer;
begin
if(a mod 2=1)then IOI:=1 else IOI:=0;
end;
begin
s:=1;
l:=1;
for i:=2 to 9 do
begin
if(IOI(i)=1)then begin
l:=l*i*(i-1);
s:=s+l;
end;
end;
writeln(s);
end.
- 24.09.2017 16:52
- thumb_up 26
На Visual Basic с массивом
Sub Program
Dim A(10) As Integer, i As Integer, S As Long
S = 0
For i = 1 To 9 Step 2
A(i) = i
S = S + Fact(A(i))
Next i
Text1.Text = S
End Sub
Function Fact(n)
Dim i As Integer
Fact = 1
For i = 1 To n
Fact = Fact * i
Next i
End Function
Почему во всех институтах изучают Pascal,
если программы на Basic короче и быстрее работают?
- 25.09.2017 14:44
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.