Вопрос по информатике:
Имеется прямоугольное отверстие со сторонами a и b и кирпич с рёбрами x, y z. Требуется составить условие прохождения кирпича в отверстие. ( Программный код нужно писать в Паскале)
- 23.10.2017 09:01
- Информатика
- remove_red_eye 5722
- thumb_up 40
Ответы и объяснения 1
Коробки
(Время: 1 сек. Память: 16 Мб Сложность: 19%)
На столе лежат коробка размера A1 × B1 × C1 и коробка размера A2 × B2 × C2. Выясните можно ли одну из этих коробок положить в другую, если разрешены повороты коробок вокруг любого ребра на угол 90 градусов.
Входные данные
Первая строка входного файла содержит три целых числа A1, B1 и C1. Вторая строка входного файла содержит три целых числа A2, B2 и C2. Все числа положительны и не превосходят 1000.
Выходные данные
Если коробки одинаковы, выведите "Boxes are equal". Если первая коробка может быть положена во вторую, выведите "The first box is smaller than the second one". Если вторая коробка может быть положена в первую, выведите "The first box is larger than the second one". Иначе, выведите "Boxes are incomparable"
program gt;
label 1;
var a,b:array[1..1000]of longint;
a1,b1,c1,a2,b2,c2,p,l,n,i,j:longint;
begin
read(a1,b1,c1,a2,b2,c2);
a[1]:=a1;a[2]:=b1;a[3]:=c1;
b[1]:=a2;b[2]:=b2;b[3]:=c2;
for i:=1 to 2 do
begin
for j:=1 to 3-i do
begin
p:=A[j];l:=A[j+1];
if A[j]>A[j+1] then begin
A[j]:=l;
A[j+1]:=p;
end;
end;
end;
for i:=1 to 2 do
begin
for j:=1 to 3-i do
begin
p:=b[j];l:=b[j+1];
if b[j]>b[j+1] then begin
b[j]:=l;
b[j+1]:=p;
end;
end;
end;
if(a[1]=b[1])and(a[2]=b[2])and(a[3]=b[3])then begin
writeln('Boxes are equal');
goto 1;
end;
if((a[1]<=b[1])and(a[2]((a[1]((a[1]<=b[1])and(a[2]<=b[2])and(a[3]writeln('The first box is smaller than the second one');
goto 1;
end;
if((a[1]>=b[1])and(a[2]>b[2])and(a[3]>=b[3]))or
((a[1]>=b[1])and(a[2]>=b[2])and(a[3]>b[3]))or
((a[1]>b[1])and(a[2]>=b[2])and(a[3]>=b[3]))then begin
writeln('The first box is larger than the second one');
goto 1;
end;
writeln('Boxes are incomparable');
1:
end.
- 24.10.2017 12:09
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.