Вопрос по информатике:
Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла) , например, файлы исходных программ Turbo Pascal. Имя просматриваемого файла должно вводится во время работы программы. Рекомендуемый вид экрана приведен ниже. Просмотр текстового файла. Введите полное имя файла и нажмите . -> d:\tp\pas\numb.pas
- 22.10.2015 07:45
- Информатика
- remove_red_eye 13807
- thumb_up 34
Ответы и объяснения 1
Var f1:text;
st:string;
begin
write ('введите имя файла ');
readln(f1);
reset (f1); { открыть файл для чтения }
while not eof (f1) do { пока не конец файла f1}
begin
readln (f1, st); {читаем строку из файла f1 }
writeln(st); { выводим на экран }
end;
close (f1); { закрыть файл для чтения}
end .
- 23.10.2015 08:06
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.