Вопрос по информатике:
1. составьте программу ввода элементов массива а[1..8] с клавиатуры и вывода на экран элементов с отрицательными значениями.
2. первое задание с листка, пункт в)
3.составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечетными значениями. (упр. 2, пункт а))
4.составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями(на картинке упр.3, пункт а) )
лучше смотрите по картинке, т.к. боюсь что где-то ошиблась....
- 16.11.2015 15:32
- Информатика
- remove_red_eye 16167
- thumb_up 49
Ответы и объяснения 1
{1}
var
a: array [1..8] of integer;
i: integer;
begin
writeln('Введите 8 элементов массива: ');
for i := 1 to 8 do read(a[i]);
for i := 1 to 8 do write(-a[i]:4);
end.
{1.в}
var
a: array [1..6] of integer;
x, i: integer;
begin
x := 3;
for i := 1 to 6 do
begin
a[i] := x;
x := x + 3;
end;
for i := 1 to 6 do write(a[i]:4);
end.
{2.а}
var
a: array [1..10] of integer;
x, i: integer;
begin
randomize;
writeln('Массив: ');
for i := 1 to 10 do
begin
a[i] := random(11);
if a[i] mod 2 0 then x := x + 1;
end;
for i := 1 to 10 do write(a[i]:4);
writeln;
writeln('Кол-во элементов с нечетными значениями: ', x);
end.
{3.а}
var
a: array [1..10] of integer;
sum, x, i: integer;
begin
randomize;
writeln('Массив: ');
for i := 1 to 10 do
begin
a[i] := random(11);
if a[i] mod 2 0 then x := x + 1
else sum := sum + a[i];
end;
for i := 1 to 10 do write(a[i]:4);
writeln;
writeln('Кол-во элементов с нечетными значениями: ', x);
writeln('Сумма элементов с четными значениями: ', sum);
end.
- 17.11.2015 15:48
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.